>>>> "Hrvoje" == Hrvoje Niksic
<hniksic(a)srce.hr> writes:
Hrvoje> Martin, we'll *have* to resolve current INLINE yuckage somehow. I,
Hrvoje> for one, would expect INLINE to expand either to `inline' or nothing.
Yup. Especially given that:
- CONST resolving to either `const' or `' suggests INLINE should
resolve to `inline' or `'.
- Stallmacs 20.2 has this (primitive) code that at least conforms to
the standard intuition:
/* If using GNU, then support inline function declarations. */
#ifdef __GNUC__
#define INLINE __inline__
#else
#define INLINE
#endif
In 21.1 we should (will?):
- nuke CONST by renaming to `const', in accord with AC_C_CONST.
- start using `inline' liberally in .c files for small or heavily
called static functions.
- rename INLINE to something more meaningful. Hmmmmm..... Can't think
of a good name .... maybe EXTERN_INLINE or HEADER_INLINE or
INLINE_FUNCTION_USED_WITHIN_MULTIPLE_COMPILATION_UNITS ??
Martin