Regardless, a new function named "progress" is too generic. Since your intent
is always to display progress gauges, regardless of implementation, you should
change "progress" to "progress-gauge". Also, there is no need to
completely
follow the "message" paradigm of function naming -- functions that perform
actions (as opposed to those that just return values) should always have a
verb in them, so a function just called "progress-gauge" is not what you want
-- something like "show-progress-gauge-fmt" if you want to distinguish
printf-like and non-printf-like functions.
Andy Piper wrote:
At 08:30 PM 10/15/99 -0700, Ben Wing wrote:
>Also, the "progress" functions are too generically-named. For
That's the point. If there becomes a better way of doing it then I don't
want to have to change code. The tty default is to show progress in the
echo area.