"Stephen J. Turnbull" <turnbull(a)sk.tsukuba.ac.jp> writes:
sb> Stephen J Turnbull <turnbull(a)sk.tsukuba.ac.jp>
writes in
sb> xemacs-beta(a)xemacs.org:
>> I think it should just go away.
sb> How else is one supposed to get Japanese menubars?
Basically, what needs to be done is to take all of the
#ifdef USE_XFONTSET
lines in lwlib/xlwmenu.c and similar conditionals in src/device-x.c and
src/event-Xt.c and change them to
#if (defined(USE_XFONTSET) || defined(HAVE_XIM))
Then the current version of input-method-xlib.c does all the work that
is needed, and --with-xfs, --with-xim=motif, and --with-xim=xlib can
and should be mutually exclusive. In that case input-method-xfs.c
needs to be synched with input-method-xlib.c (probably by deleting it
and adding `#if defined(USE_XFONTSET)' to the locale-setting code in
input-method-xlib.c. And --with-xfs should probably be renamed to
--with-multilingual-menubar. Alternatively, you could just require
--with-xim for the multilingual menubar.
--with-bilingual-menubar is correct IMHO.
Can we put multilingual characters on menubars at same time?
When I made input-method-xfs.c using a piece of code in
input-method-motif.c, I thought that I don't use X input method and
just want to have bi-lingual menu.
Since from input-method-xlib.c had added, I'd been thought that
input-method-xfs.c shound be merged with input-method-xlibc.c.
I have tested this lightly, it works, but I don't have time to
submit
a patch (I'm not synched to a recent version in either the stable or
development branch and there's other experimental stuff---failed---I
need to clean out) until next week at the earliest.
What need to be done and Stephen has done maybe...
* remove input-method-xfs.c.
* make configure to use input-method-xlib.c either
--with-xim=xlib or --with-bilingual-menubar.
* put "#ifdef HAVE_XIM" to enable XIM in input-method-xlib.c.
* get rid of "#ifndef XIM_XLIB ..." in input-method-xlib.c.
In anyway, I don't want to use X input method, but just want to have
bi-lingual menubar.
For me, XIM is evil enough though...
--
kazz